Bölüm 19. Apache, Mysql ve Php Kurulumu, Yapılandırılması

19.1. Apache (Web Sunucusu) Kurulumu

Depolarda Apache'nin 1.3.x sürümü ve 2.x sürümü mevcut. Dilediğiniz birini kurabilirsiniz. Apache 1.3.x sürümü için apt-get install apache, 2.x sürümü için ise; apt-get install apache2 uygun olacaktır.

Şayet Apache'yi tercih etmişseniz buna ilişkin ayar ana dosyası /etc/apache2/apache2.conf'dur. Ayrıca bu dosya içerisinde include ile dışarıdan bu dosyaya dahil edilmiş ayar dosyalarına da gerektiğinde göz atmanız gerekir. Apache2'nin ayar dosyalarında herhangi bir değişiklik yaptıktan sonra yeniden başlatabilmek için /etc/init.d/apache2 restart komutunu kullanabilirsiniz.

Apache2'yi tercih etmişseniz buna ilişkin ayar ana dosyası /etc/apache/httpd.conf'dur. Ayrıca bu dosya içerisinde -varsa- include ile dışarıdan bu dosyaya dahil edilmiş ayar dosyalarına da gerektiğinde göz atmanız gerekir. Apache'nin (1.3.x) ayar dosyalarında herhangi bir değişiklik yaptıktan sonra yeniden başlatabilmek için /etc/init.d/apache restart komutunu kullanabilirsiniz.

19.2. Mysql (Veritabanı Sunucusu) Kurulumu

apt-get install mysql-server

19.3. PHP Kurulumu

Şayet Apache olarak 1.3.x sürümü tercih etmişseniz mysql, komut satırı (cli), gd, pear ve xslt destekli olarak şekildeki Php kurulumunu; apt-get install php4 php4-mysql php4-cli php4-gd php4-pear php4-xslt şeklinde yapabilirsiniz.

Şayet Apache olarak 2.x sürümü tercih etmişseniz mysql, komut satırı (cli), gd, pear ve xslt destekli olarak şekildeki Php kurulumunu; apt-get install libapache2-mod-php4 php4 php4-mysql php4-cli php4-gd php4-pear php4-xslt şeklinde yapabilirsiniz.

[Not]Not

Şayet PHP için başka desteklerede ihtiyacınız varsa apt-cache search php4 şeklinde depoda yer alan paketlere bakıp uygun olanını kurabilirsiniz.

[Not]Not

Apache 2.x kullanıcıları Apache'de php4 desteği için libapache2-mod-php4 özellikle paketini kurmaya özen göstermeli. Şu anda sanıyorum Php4'de gözden kaçan ufak bir paketleme sorunu sebebiyle bu pakete olması gereken bağımlılık göz ardı edilmiş.

19.4. PhpMyAdmin Kurulumu

apt-get install phpmyadmin