Bölüm 14. Internet Uygulamaları

14.1. Web Tarayıcı

14.1.1. Mozilla Firefox

Özellikle son zamanlarda yaptığı ciddi atılımlarla Linux üzerinde en çok tercih edilen web tarayıcısı olmuştur.

apt-get install mozilla-firefox-locale-tr komutu ile kurabilirsiniz.

Kurulum sırasında tarayıcınızın sistemin varsayılan tarayıcısı olarak ayarlanabilmesi için tercih edeceğiniz yöntemi belirtebilirsiniz. Bu alanda seçimi aşağıdaki şekilde Debian olarak yapmak daha uygun olacaktır.

Şekil 14.1.

GNOME kullanıyorsanız mozilla-firefox'u varsayılan tarayıcı olarak tayin etmek için GNOME'da

Uygulamalar -> Masaüstü Tercihleri -> Gelişmiş -> Tercih Edilen Uygulamalar -> Web Tarayıcısı

kısmından Firebord/Firefox'u seçip varsayılan web tarayıcısı olarak tayin edebilirsiniz.

Yukarıdaki seçimi Debian olarak yapmış iseniz, Daha genel bir yöntem olarak update-alternatives komutunu kullanabilirsiniz. Bunun içinde update-alternatives x-www-browser komutunu işleterek gelen menüden Firefox'un id'sini öğrenip, girerek Firefox'un varsayılan web tarayısı olmasını sağlayabiliriz.

14.1.2. Konqueror

14.1.3. Elinks

14.1.4. Lynx

14.2. Tarayıcılarda Macromedia Flash Desteği

Flash desteği için http://fpdownload.macromedia.com/get/shockwave/flash/english/linux/7.0r25/install_flash_player_7_linux.tar.gz dosyasını indirip kurmamız gerekecek. Daha öncesinde apt-get install gsfonts gsfonts-x11 ile gsfonts ve gsfonts-x11 paketlerini kuralım. Daha sonra;

cd /tmp/
wget  http://fpdownload.macromedia.com/get/shockwave/flash/english/linux/7.0r25/install_flash_player_7_linux.tar.gz
tar -zxvf install_flash_player_7_linux.tar.gz
cd install_flash_player_7_linux
./flashplayer-installer

Şimdi, Flash desteğini vermek istediğimiz tarayıcının yolunu belirteceğiz. Mesela mozilla-firefox için /usr/lib/mozilla-firefox yolunu girip enter ile kurulumu gerçekleştireceğiz.

Aslında bu işlem flashplayer.xpt ve libflashplayer.so dosyalarının tarayıcının plugins dizinine aktarılmasından farklı bir işlem değildir. Dilerseniz bu işlemi elle de yapabilirsiniz.

Benzer yöntem ile diğer tarayıcılara da flash desteği verebilirsiniz. Tarayıcının birisine bu desteği verdikten sonra diğerlerine de vermek için daha farklı bir yöntemde izleyebilirsiniz. Mesela, mozilla-firefox'a destek verdikten sonra Konquerorde de bu desteği sağlamak için;

Ayarlardan, Konqueror programını yapılandır seçiniz, gelen pencerenin sol tarafında Eklentiler kısmını seçip Eklentileri Tara seçeği ile eklentinin otomatik olarak bulunmasını sağlayabilirsiniz. Ayrıca dilerseniz, Aynı kısımda yer alan Açılışta eklentileri tara seçeneğini aktif edip işlemlerin otomatik yapılmasını sağlayabilirsiniz.

14.3. Tarayıcılarda Java Desteği

Lisans problemlerinden dolayı java paketi Debian depolarında yer almaz. Java binary dosyasını www.java.com adresinden alıp Debian metodlarıyla .deb paketini oluşturup kuracağız.

Öncelikle /etc/apt/sources.list dosyasındaki depo kaynaklarında contrib bölümünün olduğuna emin olunuz. Yani;

deb http://ftp.tr.debian.org/debian testing main contrib non-free

şeklindeki kayıt /etc/apt/sources.list dosyanızda olmalı. Burada önemli olan contrib bölümünün yer almasıdır.

Önce dosyalarımızı bulunduracağımız geçiçi bir dizin oluşturalım. Mesela tempjava gibi.

[Not]Not

Bu dizinin normal kullanıcılar tarafından da yazılabilir halde olması önemli. Zira daha sonraki adımda normal kullanıcı olarak yapacağımız .deb paketi oluşturma işleminde, işlemi uyguladığımız kullanıcının o dizine yazma hakkı yoksa problem olacaktır. Bu açıdan bu dizinin /tmp gibi herkes tarafından yazma/okuma hakkı olan bir dizin olması uygun olur.

mkdir tempjava (mkdir /tmp/tempjava daha uygun olabilir)

Ardından http://www.java.com/en/download/manual.jsp adresinden Linux (self-extracting file) dosyasını javatemp dizinine indirelim.

İndirmiş olduğumuz dosya jre-1_5_0_02-linux-i586.bin gibi olacaktır. Sizdeki daha güncel bir versiyon olabilir.

apt-get install java-package
cd tempjava (veya cd /tmp/tempjava)

Şimdi işlemlerimizi normal kullanıcı (root yetkisiyle değil) yapacağız. Aşağıdaki şekilde paketi oluşturalım;

fakeroot make-jpkg jre-1_5_0_02-linux-i586.bin (sizde bu dosya daha farklı güncel bir sürüm olabilir)

Sorulan sorulara yanıt verdikten sonra bulunduğumuz dizin içerisinde sun-j2re1.5_1.5.0+update02_i386.deb benzeri bir dosya oluşacak.

Şimdi root yetkilerine sahip olup dpkg -i sun-j2re1.5_1.5.0+update02_i386.deb şeklinde oluşan paketimizi kuralım.

Paketimiz otomatik olarak tarayıcılara gerekli desteği verecektir. Dilerseniz tarayıcımızın plugins dizininde gerekli bağlantının sağlanıp sağlanmadığını kontrol edelim. Mesela mozilla-firefox için;

ln -s /usr/lib/j2sdk1.5-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/mozilla-firefox/plugins/libjavaplugin_oji.so

veya

ln -s /etc/alternatives/firefox-javaplugin.so /usr/lib/mozilla-firefox/plugins/libjavaplugin_oji.so

şeklinde bağlantının oluşmuş olması gerekir.

Benzer yöntem ile diğer tarayıcılara da java desteği verebilirsiniz. Tarayıcının birisine bu desteği verdikten sonra diğerlerine de vermek için daha farklı bir yöntemde izleyebilirsiniz. Mesela, mozilla-firefox'a destek verdikten sonra Konquerorde de bu desteği sağlamak için;

Ayarlardan, Konqueror programını yapılandır seçiniz, gelen pencerenin sol tarafında Eklentiler kısmını seçip Eklentileri Tara seçeği ile eklentinin otomatik olarak bulunmasını sağlayabilirsiniz. Ayrıca dilerseniz, Aynı kısımda yer alan Açılışta eklentileri tara seçeneğini aktif edip işlemlerin otomatik yapılmasını sağlayabilirsiniz.

Tarayıcınızın Java desteğini test etmek isterseniz, http://www.java.com/en/download/help/testvm.jsp adresini ziyaret edebilirsiniz.

[Not]Not

Java desteği için yukarıdaki yöntemlerle paketi oluşturup kurmanız yeterli olacaktır. Sonraki bilgiler sadece konrol amaçlı veya olası problemlerin tespit edilebilmesi amacı ile verilmiştir.

14.4. E-posta Okuyucusu

14.4.1. Evolution

En çok tercih edilen e-posta okuyuculardandır. Sisteminize Gnome'u komple yüklemişseniz evolution'da sisteminize yüklenmiş olacaktır.

Evolution e-posta okuyucusu olarak görev yapabilmenin yanında, takvim, adres, organizasyonel işleri belirleme, takip etme vb. gibi işlemleride yapabilir.

Evolution sisteminizde yüklü değilse, apt-get intall evolution ile kolayca yükleyebilirsiniz.

Evolution ile ilgili daha geniş bilgiye http://www.novell.com/products/desktop/features/evolution.html adresinden ulaşabilirsiniz.

14.4.2. Thunderbird

Mozilla'nın e-posta okuyucusu projesi olan Tunderbird, yine çok tercih edilen e-posta okuyucularındandır.

apt-get install mozilla-thunderbird komutu ile sisteminize yükleyebilirsiniz. Thunderbird'ün Türkçe Dil Paketi şu an için sadece unstable deposunda bulunmaktadır. Bu pakete de http://packages.debian.org/mozilla-thunderbird-locale-tr adresinden ulaşıp dpkg ile kurabilirsiniz. Veya Thunderbird'ü komple unstable deposundan kurabilirsiniz. Zaten unstable depoyu kullanıyorsanız sorun olmayacaktır, unstable depoyu kullananlar apt-get install mozilla-thunderbird-locale-tr komutunu kullanabilirler.

14.4.3. Sylpheed

Sylpheed'de çoğu kullanıcılar tarafından tercih edilen e-posta ve haber okuyucusudur. apt-get install sylpheed şeklinde kurabilirsiniz. Dilerseniz Sylpheed'in biraz d aha uç noktasına çıkabilirsiniz. Bunun için apt-get install sylpheed-claws komutu ile kurulum yapabilirsiniz. sylpheed-claws serisi, Spam, Antivirus gibi eklentilere sahiptir.

Clam antivirus için apt-get install sylpheed-claws-clamav, Spam kontrolü için; apt-get install sylpheed-claws-spamassassin ve Dil desteği için; apt-get install sylpheed-claws-i18n şeklinde kurulum yapabilirsiniz.

Sylpheed ile ilgili sıkça sorulan soruların yanıtlarına Türkçe çevirisine http://linux.fisek.com.tr/dfisek/sylpheed-sss.html adresinden ulaşabilirsiniz.

14.4.4. Mutt

En yetenekli MUA'lardan birisidir. Konsolda çalışır. apt-get install mutt ile kurup yine konsoldan mutt ile çalıştırabilirsiniz.

14.5. Haber (News) Okuyucusu

14.5.1. Knode

Knode KDE haber okuyucu yazılımıdır. Kurulum için apt-get install knode

14.5.2. Pan

Pan en çok tercih edilen haber okuyuculardandır. apt-get install pan komutu ile kurabilirsiniz.

Daha detaylı bilgi için http://pan.rebelbase.com. Ayrıca ekran görüntülerine http://pan.rebelbase.com/screenshots/ adresinden ulaşabilirsiniz.

14.5.3. Tin

Tin konsolda çalışan haber okucuyu programıdır. apt-get install tin şeklinde kurabilirsiniz.

Detaylı bilgi için http://www.tin.org

14.5.4. Trn

Trn 'de Tin gibi konsoldan çalışan haber okuyucu programıdır. Kurulum için apt-get install trn

14.5.5. Xrn

Xrn X tabanlı haber okuyucu programıdır. apt-get install xrn şeklinde kurabilirsiniz.

14.6. Anında Mesajlaşma Yazılımları

14.6.1. Icq/Msn/Jabber

14.6.1.1. Sim

Sim en kullanışlı ICQ istemcilerinden birisidir. Hangi depoda yer aldığına yukarıdaki adresten bakıp, ilgili depodan kurabilirsiniz.

14.6.1.2. Gaim

Gaim farklı protokollere desteği vardır. apt-get install gaim şeklinde kurabilirsiniz

14.6.1.3. Kopete

Kopete

14.6.1.4. Amsn

Amsn

14.6.1.5. gabber

Gabber

14.6.1.6. gnome-jabber

Gnome-jabber

14.6.2. IRC

14.6.2.1. Xchat

Xchat

14.6.2.2. Ksirc

Ksirc

14.6.2.3. Kvirc

Kvirc

14.6.2.4. Irssi-Text

Irssi-Text

14.6.2.5. Scrollz

Scrollz

14.6.2.6. Pork

Pork

14.6.2.7. Mozilla-chatzilla

Mozilla-chatzilla

14.7. Görüntülü ve Sesli Konferans Yazılımları

14.7.2. Gaim-vv

14.7.3. GnomeMeeting

GnomeMeeting

14.8. FTP İstemcileri

14.8.1. Gftp

Gftp

14.8.2. Yafc

Yafc

14.8.3. Ncftp

Ncftp

14.8.4. Lftp

Lftp

14.8.5. Cftp

Cftp

14.9. Dosya İndirme Yönetim Programları

14.9.1. Prozilla

Prozilla

Prozgui

14.9.2. Axel

Axel

Axel-kapt

14.9.3. Aget

Aget

14.9.4. D4x

D4x

14.9.5. Kget

Kget

14.9.6. Wget

Wget

14.10. P2P Programları

14.10.1. KMldonkey

KMldonkey

14.10.2. Gift

Gift

14.10.3. Amule

Amule

14.10.4. Opendchub

Opendchub